EasyApache 21 July Maintenance Update

SUMMARY
cPanel, Inc. has released updated RPMs for EasyApache 4 on July 21, 2016, with Apache version 2.4.23 and patches to Apache 2.4 for the HTTPROXY vulnerability. This release addresses vulnerabilities related to CVE-2016-1546, CVE-2016-4979, and CVE-2016-5387. We strongly encourage all EasyApache 4 users to update their RPMs and all Apache 2.4 users to upgrade to version 2.4.23.

AFFECTED VERSIONS

All versions of EasyApache through July 21, 2016
All versions of Apache 2.4 through version 2.4.20

SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2016-1546 – Medium
Apache 2.4.20
Fixed bug in mod_http2 related to CVE-2016-1546

CVE-2016-4979 – High
Apache 2.4.20
Fixed bug in mod_ssl related to CVE-2016-4979.

CVE-2016-5387 – HIGH
Apache 2.4
Patched Apache 2.4 for HTTPOXY vulnerability.

SOLUTION
cPanel, Inc. has released updated RPMs for EasyApache 4 on July 21, 2016, with an updated version of Apache 2.4.23 and updated RPMS for EasyApache 4. Unless you have enabled automatic RPM updates in your cron, update your system with either yum update or WHM’s Run System Update interface.

REFERENCES
https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-1546
https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-4979
https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-5387
http://www.apache.org/dist/httpd/CHANGES_2.4
https://www.apache.org/security/asf-httpoxy-response.txt
https://documentation.cpanel.net/display/CKB/CVE-2016-5387+HTTPOXY
—–BEGIN PGP SIGNATURE—–
Comment: GPGTools – https://gpgtools.org

For the PGP-signed message, please see EA4 2016-7-21 CVE

Comments are closed.